Mitsubishi Eclipse 3G Club banner

1 - 8 of 8 Posts

·
Ur a worthless noob
Joined
·
12,194 Posts
Discussion Starter #1
Mine finally showed up after one song on Guitar Hero. I turned it off and it worked again for half of a song. Turned it off and it did it again. However, on the 4th try, it hasnt showed up again but I dont really play the 360.

I did the Microsoft repair thing online and I got the box to send it in. But, should I? I mean it hasnt showed up again. And what if Microsoft says nothing is wrong with it?
 

·
MINI by proxy
Joined
·
4,408 Posts
From what I've heard, they've pretty much got a "no questions asked" policy on Red Ring o' Death claims. I say return it and get a new one; yours may be on its way out.
 

·
Registered
Joined
·
13,210 Posts
Mine finally showed up after one song on Guitar Hero. I turned it off and it worked again for half of a song. Turned it off and it did it again. However, on the 4th try, it hasnt showed up again but I dont really play the 360.

I did the Microsoft repair thing online and I got the box to send it in. But, should I? I mean it hasnt showed up again. And what if Microsoft says nothing is wrong with it?
You might as well send it in, I don't think missing out on the 360 for a few days will kill you. From what I've read, Microsoft has a pretty good turn-around time with these things.
 

·
Registered
Joined
·
1,960 Posts
Do it before your warranty is up. I just got an error code too and 1 red ring. Error 068 or something. I called them up and they helped me. Better safe then sorry..
 

·
Ur a worthless noob
Joined
·
12,194 Posts
Discussion Starter #6
I packaged it up and Ill send it out before or during work. I rarely use the Xbox and I thought the 3RoD shows up for those who actually play it :dunno:

Either way, mine is kinda old. I bought it from Phil a few months after launch, I think...dont remember. But then again, I do use my ps3 and it will keep me happy til the 360 gets repaired/replaced :lol:
 

·
It's TEE not TE, wtf
Joined
·
4,202 Posts
Mine's been gone for 2 weeks. It says on the MS Support website that it is on the way back...

Mine did the same thing, worked sometimes, then didn't. What a tease.
 
1 - 8 of 8 Posts
Top