Mitsubishi Eclipse 3G Club banner

1 - 12 of 12 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter #1
Has any one tryed putting and aftermarket BOV on the rippmods kit. Im still waiting for my kit to get here and i know that the BOV that comes with the stage 2.5 is kinda quiet and not as high quality as the rest of the kit.(heard first hand from alot of people with the kit at carshows).
 

·
Registered
Joined
·
970 Posts
I am very happy with mine as well ? Their has been a lot of discussion about this topic that you could find by searching probably. Basically it has to be a Vortech approved BOV otherwise the warranty on the blower is null and void so be very careful what you do to change the kit. Your best bet is to stick with RIPPs stuff IMHO.
 

·
Registered
Joined
·
261 Posts
npeifer said:
I am very happy with mine as well ? Their has been a lot of discussion about this topic that you could find by searching probably. Basically it has to be a Vortech approved BOV otherwise the warranty on the blower is null and void so be very careful what you do to change the kit. Your best bet is to stick with RIPPs stuff IMHO.

They'd be hard pressed to prove what bypass valve you were using, don't you think?
 

·
Registered
Joined
·
1,100 Posts
Isn't the BOV supposed to be kinda puffing out air at idle and then close up when you rev it up? Mine does the opposite and its not very loud either. Could it be on backwards? Would that make a difference?
 

·
ol' #4
Joined
·
225 Posts
YourMine said:
Isn't the BOV supposed to be kinda puffing out air at idle and then close up when you rev it up? Mine does the opposite and its not very loud either. Could it be on backwards? Would that make a difference?
Yep there should be a steady stream of air coming out the long cut-outs towards the bottom. If its not doing this while your car is at idle, very slowly turn the top of it one way or the other. It should then just pop open and bleed air. You must turn it very slowly to find that perfect spot.
 

·
Registered
Joined
·
1,100 Posts
I did that. Found that i needed to get some lock lube (its that graphite dust) to lube up the plunger cause it wasn't moving. It opens up and closes fine now, but doesn't really blow any air out of the slots.
 
1 - 12 of 12 Posts
Top