Mitsubishi Eclipse 3G Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
652 Posts
Discussion Starter #1
I just bought a Belkin G Plus MIMO router and I can't get the internet connection set up right. I bought it because I think something happened to the modem that I had my Xbox Live hooked up to. Does anyone have any ideas why it won't work? I really want Xbox Live back, but it isn't working out for me. If I need to give more info, just tell me.
 

·
From the Internet
Joined
·
2,303 Posts
A modem and router are 2 different things, but yeah if you had the xbox hooked up to a modem, then it should work. In the event it went bad, you'd need to get a new modem. The routher hooks into the modem and then whatever devices need the internet hook into the router (your xbox). A router is what splits the connection and assigns IP addresses to anything using it....like a laptop, xbox, wii, certain cell phones, etc. Also, if you passworded your router's connection, then make sure it's the same one on the xbox.
 

·
BoomGoesTheDynaMitt
Joined
·
7,180 Posts
Unplug the power adapters/cords from all the network devices. Hook your new router's "WAN" port to your ISP's modem. Hook your Xbox into one of the router's "LAN" ports (usually labeled #1-4). You should only be using normal ethernet cables (no crossover cables). Once you have the ethernet cables patched in plug the power cable into the modem. Then plug the power cable into the router. Then plug the power cable into the Xbox. If that doesn't work then you most likely have broken hardware and something needs to be replaced.

Post up if you are still having issues.
 

·
Registered
Joined
·
652 Posts
Discussion Starter #4
I tried everything possible, so I just ordered a new modem. I'm pretty sure something was wrong with it because the ethernet light only comes on when there is NOT a cable in it. When I plug a cable into it, the light goes off. So the new modem should be here in a few days and hopefully it fixes my problems.
 

·
BoomGoesTheDynaMitt
Joined
·
7,180 Posts
Cool. Definately sounds like a modem issue if the "ethernet light" you are referring to is on the modem. The ISP should be replacing it for free.
 

·
Registered
Joined
·
652 Posts
Discussion Starter #6
Actually, I have to pay for it, and I have to pay for shipping. (BS if you ask me) They said something about $2 a month for as long as I have it, so I think that means I am paying for it.
 

·
Registered
Joined
·
652 Posts
Discussion Starter #9
Ok, so I got the new modem in...and I've come up with the conclusion that I need a new Xbox 360. The reason I say this is because I can hook my regular Xbox up to xbox live, but when I try to hook up the 360, it says that it is not connected. So hopefully they will replace the one I have...
 

·
BoomGoesTheDynaMitt
Joined
·
7,180 Posts
Actually, I have to pay for it, and I have to pay for shipping. (BS if you ask me) They said something about $2 a month for as long as I have it, so I think that means I am paying for it.
Sounds like they tested the modem and it worked and you said send a new one anyway. For $2/mo you are most likely just leasing the modem. Some companies won't even cancel your service until you have returned the modem at your own expense. If any device you own can connect to the internet then the modem is fine.

My guess is you need a new account withe the 360 but I dunno... I'm a PS3 guy.
 

·
Registered
Joined
·
652 Posts
Discussion Starter #11
Sounds like they tested the modem and it worked and you said send a new one anyway. For $2/mo you are most likely just leasing the modem. Some companies won't even cancel your service until you have returned the modem at your own expense. If any device you own can connect to the internet then the modem is fine.

My guess is you need a new account withe the 360 but I dunno... I'm a PS3 guy.
When I told the people my problem, they put me on hold for about 5 minutes, then said that I need a new modem and that they would transfer me to customer service. It is the exact same modem that I had my 360 hooked up to earlier when the live worked, so it should be working. Also, since it is the exact same modem that we had, I still don't understand why we have to pay for it...
 
1 - 11 of 11 Posts
Top