Mitsubishi Eclipse 3G Club banner

1 - 15 of 15 Posts

·
Dr 9023G = SCUM
Joined
·
1,447 Posts
Discussion Starter #1
Temperatures here in MI dropped down below 20 degrees again, and my car won't stay running. As soon as it stalls, I can't restart the car again until I let it sit for an hour or so.
Last week when the temperatures were in the 40s and 50s the car ran much better.
I'd like to here from other SDS cars in cold climate if they are having any issues or if there car has no issues regardless of temperature.
 

·
Dr 9023G = SCUM
Joined
·
1,447 Posts
Discussion Starter #3
5 Speed here.
Took it to the shop last night, so we'll see what they say. I'm currently running the Black Box, but I have the Grey Box ready for install.

Anybody have any comments on the Grey Box? Debating on installing that or the Greddy E-Manage.
 

·
Registered
Joined
·
970 Posts
Duhh001 said:
5 Speed here.
Took it to the shop last night, so we'll see what they say. I'm currently running the Black Box, but I have the Grey Box ready for install.

Anybody have any comments on the Grey Box? Debating on installing that or the Greddy E-Manage.

My car makes in the 400whp range with the GB and runs like stock as far as idle etc.

Why would you want to screw with the emanage when the GB is a plug in for you ?
 

·
Dr 9023G = SCUM
Joined
·
1,447 Posts
Discussion Starter #5
npeifer said:
My car makes in the 400whp range with the GB and runs like stock as far as idle etc.

Why would you want to screw with the emanage when the GB is a plug in for you ?

If the Grey Box will work, then I've got no problem using it. Checking out the link above someone else is having the same issues with the Grey Box.

What program are you running? I'm running around 320whp, when tuned up properly.
 

·
Dr 9023G = SCUM
Joined
·
1,447 Posts
Discussion Starter #7
rippedeclipse said:
i have the black box but i send it in a got ripps latest tune does that mean it is the grey insides
No the box is actually Grey. What's the temp. where you're at? And how's you car running.

Also list your setup.

Trying to see who's got what, and what's actually working in the very cold weather.
 

·
Registered
Joined
·
127 Posts
I talked to Ross. Problem is, if you got an auto, there ain't much the gray box can do during warm up phase. They are working on ideas, we discussed some of them, it's gonna take ideas from the community to fix. Fake out load on auto like it is in gear, etc. Damn thing is just to smart for it's own good.
 

·
Dr 9023G = SCUM
Joined
·
1,447 Posts
Discussion Starter #10
rippedeclipse said:
i have ripp stage 2 5-speed it was ok in the cold didn't drive it much though
Stock internals or Forged Pistons?

Mines still going though tests to determine what the issues are. As soon as it starts up in the cold it overloads the fuel & runs rich until it stalls out.
 
C

·
Guest
Joined
·
0 Posts
When I still had my Eclipse, I only had two incidents when it stalled out and wouldn't start back up right away, but I only had to wait about 5 minutes. If I remember correctly, both times I was running the gray box. My car was an '02 5-speed, stage 1 sds @ 8psi, all stock internals, also in Michigan. I can't remember if the Eclipse has some type of air temp. sensor that will automatically change fuel delivery, but that could be a possibility. I know that my srt-4 will vary boost and fuel delivery by huge margins depending on the temp and humidity. The cold startup on my Eclipse was always much worse in the colder weather.
 

·
Registered
Joined
·
127 Posts
> Stock internals or Forged Pistons?

Questions wasn't directed at me but forged pistons here- running a full stage 3 setup.

Car starts right up, no problem, 15-30 seconds into is where the problems start. MAS sees tons of air, it runs rich, floods the hell out of it with those huge injectors and that's all she wrote. Funny thing is, if I start the car, fully apply the parking brake, put it into Drive, car will still stall out. If I do the same thing, same temperature, but put it in reverse, it stays running. I have tried this many times, reverse works, drive does not. Scary thing thing is about 1 and 1/2 minutes into warm up, idle goes way up say 2300 rpm for a second and car jerks, not a good thing when you are scrapping the ice of the windshield. Scares the shit out of yah. Anywho this hs been my experience.
 

·
Dr 9023G = SCUM
Joined
·
1,447 Posts
Discussion Starter #13
Interesting posts. I'm still out my car for awhile, while AutoWerk & RIPP diagnois the problem.

I thought it was quite weird that as I first the start I have the clutch in, and when I go to release the clutch into neutral, it would try to stall out. I also ran my car with the foot on the gas for 20 minutes to warm up the car and it still would stall as soon as I took my foot of the gas.

Should have some updated reports from AutoWerks next week hopefully
 

·
SPYDEY MF!
Joined
·
5,223 Posts
I have a 03 sporty GT spyder, so if I get the Stage 1 SDS and it gets real cold, will I have this problem with my car? I live in Roanoke, VA but go to UVa Wise in the mountains, and it gets real cold here. I am kinda worried about this problem. I won't be ordering my SDS till the end of the year, which will hopefully give them time enough to figure out what modification needs to be done. Love the car SlowPoke ;). I have an identical car, gotta love the Ti. Pearl. Your ride is sick man.
 

·
RIPPerized
Joined
·
46 Posts
2004 Dodge R/T coupe with autostick, stock pistons, and stage 2 SDS in Newport News, VA. The black box has the latest tune and I have the same idle and run-off problems, but not flooding when restarting. I have noticed that if the ambient air temperature is below 32°F it is much, much worse. I even have run-off problems after the car is warm.
 
1 - 15 of 15 Posts
Top