Mitsubishi Eclipse 3G Club banner

1 - 20 of 52 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
Heres the scenario...
I was on the highway and was trying to pass a car...first I got a GT with a t3/t4 turbo, front mount intercooler...so anyways..I boot my car in thrid on the highway, and boom, a cloud of blacj smoke out of my exhaust and then lose of power. Now the car is running, but is shaking. And when im cruising its not smooth and theres a loss of pwer. The car struggles now to get past 3500 rpms, and its running rough. It seems like its running on limited cylinders. When I get on it a bit to try to spool the turbo, I can only get to 3500 rpm until the car feels like its struggles, but enough pressure to make boost, but you dont here the blow off valve or nothing. Has anyone encountered this problem? I do have exahust smoek coming out of my exhaust, but I ahd it in the first place because my first turbo blew smoke out of my exhaust a lot and I have left over in my piping. Please let me know what the problem might be.
Thanks everyone.
Stro
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
If my motor was blown, would it still be able to somewhat drive a bit? I thought when i motor was blown there was no way of it moving or driving it.
 

·
Kampfbereit
Joined
·
17,852 Posts
JoeStro1477 said:
If my motor was blown, would it still be able to somewhat drive a bit? I thought when i motor was blown there was no way of it moving or driving it.
You can still drive on a motor with chipped pistons, yes. Ryu for instance had 4 out of 6 pistons chipped on his motor at one time. But you may hear a tapping noise from time to time though.
 

·
REDLINE ALL GEARS
Joined
·
5,039 Posts
your located in virginia beach correct. You should do what was mentioned above. Also do you have any SES lights. If you do i could run my data logger on your car if you want
 

·
Evo IX
Joined
·
1,767 Posts
Tearstone said:
You can still drive on a motor with chipped pistons, yes. Ryu for instance had 4 out of 6 pistons chipped on his motor at one time. But you may hear a tapping noise from time to time though.
and I still managed to keep up with that 340whp stage 3 Roush :lol:
 

·
REDLINE ALL GEARS
Joined
·
5,039 Posts
sometimes its not engine problems. Theres a slight chance it could be something else. The reason i say this is because a buddy of mine posted a while back with the same problem. Come to find out he was running too rich and he had unknown stuff in his turbo. Only way to narrow it down some is to do a compression test.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #20
The car was tuned on a wide band Dyno...not through the SAFC II.
.63 trim and I will look at my receipt for the specs again. It is a turbo that spooled quicker than the one that came with the Xtech
 
1 - 20 of 52 Posts
Top