Mitsubishi Eclipse 3G Club banner

61 - 80 of 82 Posts

·
Registered
Joined
·
496 Posts
Big update.

The engine finally fired. I'll give alot of credit to Mysticj for making really look harder and brush back up on my electronic diagram reading skills. I was getting advice from several other sources saying that the coils didn't have built in ignitors (which they do) and I wired in a separate Haltech ignitor, which was wrong. The engine would have fired on my first attempt, when I originally wired the coils directly to the Haltech, but I found out that the ignition drivers in my Haltech were fried. Once those were fixed and the coils were re-wired how I had them initially, the engine fired.

The idle is very rough. I'm going to have my injectors checked, to make sure there isn't an issue since my car has been sitting for an extended period of time.

My tach isn't working. I'm not sure why, I'll check fuses, but my next task will be to figure out how the tach receives its signal. While the injectors are getting checked, I'll button up some of the loose ends of the swap. Maybe I'll get it running well enough to drive it for a week!
Idling rough like running on one bank, misfiring?
 

·
Registered
Joined
·
225 Posts
Discussion Starter #64
Idling rough like running on one bank, misfiring?
It seems like an injector might not be working correctly. If the rpms are raised the idle seems to smooth out, but much past that point and the engine starts to run roughly again. Im going to have to check the timing and the tune, I'm not sure if the timing was even set.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #65
The mystery of the rough idle has just about been figured out! I took apart my fuel system to send the injectors into RC Engineering to be cleaning, thinking that because they have sat for such a long time, they may be been clogged. I got a call today from RC saying that one of my injectors has an external leak and cannot be repaired. So, they are going to see if they have a replacement injector and everything should be fine once they are installed back on my car.

 

·
Resident Auto Maniac
Joined
·
358 Posts
Nice update!
 

·
Registered
Joined
·
225 Posts
Discussion Starter #67
Last week I got the injectors back from being cleaned. Last night I installed them back on the car.
next step will be to install the upper intake manifold this coming weekend. I also have to figure out the right spark plug heat range for this setup. With the stock 6g75 compression being higher then the 72 and boost will probably be around 10-13 psi probably 2 steps colder.
 

·
Registered
Joined
·
12,548 Posts
If you get 12 pounds on the 3.8 I will be surprised. If you get it on the 3.8 for more than a month I will eat a pair of shorts.
 

·
REDLINE ALL GEARS
Joined
·
5,039 Posts
Well, that's what the stage one pulley would spike at on my 72 setup.
yea thats what i was using as a comparison but its weird that cody only get 8psi on my stage 1 pulley. I know your blower is slightly bigger so it might be a different story on your set up
 

·
Registered
Joined
·
225 Posts
Discussion Starter #72
yea thats what i was using as a comparison but its weird that cody only get 8psi on my stage 1 pulley. I know your blower is slightly bigger so it might be a different story on your set up
If you are talking about who I think you are, his stage one pulley is different than mine. I believe his pulley was from a 4g sds kit which had a larger pulley than the 3g ads kit.
 

·
REDLINE ALL GEARS
Joined
·
5,039 Posts
If you are talking about who I think you are, his stage one pulley is different than mine. I believe his pulley was from a 4g sds kit which had a larger pulley than the 3g ads kit.
Yea were talking about the same guy. He actually used my pulley vs the 4g sds kit pulley
 

·
Registered
Joined
·
225 Posts
Discussion Starter #76
Yep, though swapping pulleys is trivial at this point. Upgrading is easy compared to the rest.
Upgrading to a smaller pulley is easy compared to all of the other mods I've done to this point? I agree with that. I'm not trying to hit high "boost" numbers. I realize that the 75 is a higher compression motor then the 72 and that mine is stock...for now. I would like to get a year or so out of the stock 75 so the lower the boost the better with a nice conservative tune.
 

·
REDLINE ALL GEARS
Joined
·
5,039 Posts
yep only made 8psi but he ran a non intercool set up. Not sure if that plays a role. I didnt think it would. Hell i was only seeing 10psi on my stage one pulley with a v3 set up
 

·
Registered
Joined
·
225 Posts
Discussion Starter #79


First official start. Almost no tuning and it idles fairly well. My 72 tune was wiped completely off my haltech when the ignition drivers were replaced. Anyone have a haltech E8 base map for a 75 with an SDS? :p
 

·
Registered
Joined
·
496 Posts


First official start. Almost no tuning and it idles fairly well. My 72 tune was wiped completely off my haltech when the ignition drivers were replaced. Anyone have a haltech E8 base map for a 75 with an SDS? :p
Good, glad to see it running. Now if only a certain 6G75 Avenger gets its speed density dial in.
 
61 - 80 of 82 Posts
Top