Mitsubishi Eclipse 3G Club banner
1 - 16 of 16 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Last night i decided to drive fast in my 03 gt auto w/ 66k . I got it up to 70 in 2nd gear and then stopped accelerating and shifted to 3rd then 4th and stopped at a stop sign. When i tried going i got nothing. My car will only move when i rev it up to 1.5k - 2k and then it will catch and jerk alittle. When my car is moving and when it shifts to the next gear its slips a couple of times then goes into the next gear. It does this everything it shifts into a higher gear. After a while driving like this the car will put itself into limp mode with the neutral light flashing and stuck in 3rd. The SES light came on and i got the codes p0734 and p0733 both 3rd and 4th gear ratio incorrect? I was wondering if anyone had the same problem and what would the possible solution would be. I have had 2 transmission shops says its prob internal and that i would need a rebuild.
 

·
Moderator
Joined
·
54,481 Posts
Last night i decided to drive fast in my 03 gt auto w/ 66k . I got it up to 70 in 2nd gear and then stopped accelerating and shifted to 3rd then 4th and stopped at a stop sign. When i tried going i got nothing. My car will only move when i rev it up to 1.5k - 2k and then it will catch and jerk alittle. When my car is moving and when it shifts to the next gear its slips a couple of times then goes into the next gear. It does this everything it shifts into a higher gear. After a while driving like this the car will put itself into limp mode with the neutral light flashing and stuck in 3rd. The SES light came on and i got the codes p0734 and p0733 both 3rd and 4th gear ratio incorrect? I was wondering if anyone had the same problem and what would the possible solution would be. I have had 2 transmission shops says its prob internal and that i would need a rebuild.
they may be correct, is the fluid burnt of heavily discolored?
 

·
Titanium Spork
Joined
·
9,045 Posts
a friend of mine had the same symptoms, and it turned out it was his torque converter. (coincidentally it was right after bashing the tranny from stop to fast and back then fast again...street racing like and idiot from light to light).
 

·
Waiting to spool
Joined
·
3,237 Posts
Sounds like a torque converter to me too.
 

·
Registered
Joined
·
10 Posts
My car just did this to me last night! jerkin all over the place, slammin into gears, flashing neutral, the whole bit! i parked it and dont plan on moving it. so far i have come up with Torque converter, speed sensors, rebuild, replace, pump, or fluid issues.... i have no idea whats wrong with mine specifically but my issue is getting my tranny out of my car so i can do what i gotta do. can anyone direct me to resources i can use to remove my (Auto, 3.0) Transmission????? i want to fix this thing and FAST.
 

·
Registered
Joined
·
2 Posts
My car just did this to me last night! jerkin all over the place, slammin into gears, flashing neutral, the whole bit! i parked it and dont plan on moving it. so far i have come up with Torque converter, speed sensors, rebuild, replace, pump, or fluid issues.... i have no idea whats wrong with mine specifically but my issue is getting my tranny out of my car so i can do what i gotta do. can anyone direct me to resources i can use to remove my (Auto, 3.0) Transmission????? i want to fix this thing and FAST.
Did you ever figured what it was?
 

·
Registered
Joined
·
2 Posts
Last night i decided to drive fast in my 03 gt auto w/ 66k . I got it up to 70 in 2nd gear and then stopped accelerating and shifted to 3rd then 4th and stopped at a stop sign. When i tried going i got nothing. My car will only move when i rev it up to 1.5k - 2k and then it will catch and jerk alittle. When my car is moving and when it shifts to the next gear its slips a couple of times then goes into the next gear. It does this everything it shifts into a higher gear. After a while driving like this the car will put itself into limp mode with the neutral light flashing and stuck in 3rd. The SES light came on and i got the codes p0734 and p0733 both 3rd and 4th gear ratio incorrect? I was wondering if anyone had the same problem and what would the possible solution would be. I have had 2 transmission shops says its prob internal and that i would need a rebuild.
Did you ever figured it out?
 

·
Registered
Joined
·
28 Posts
Last night i decided to drive fast in my 03 gt auto w/ 66k . I got it up to 70 in 2nd gear and then stopped accelerating and shifted to 3rd then 4th and stopped at a stop sign. When i tried going i got nothing. My car will only move when i rev it up to 1.5k - 2k and then it will catch and jerk alittle. When my car is moving and when it shifts to the next gear its slips a couple of times then goes into the next gear. It does this everything it shifts into a higher gear. After a while driving like this the car will put itself into limp mode with the neutral light flashing and stuck in 3rd. The SES light came on and i got the codes p0734 and p0733 both 3rd and 4th gear ratio incorrect? I was wondering if anyone had the same problem and what would the possible solution would be. I have had 2 transmission shops says its prob internal and that i would need a rebuild.
When first gear is out and third or fourth gear are having problem codes, it is time to rebiuld the tranny with new parts. The speed sensor going out on Mitsubishi vehicles is rare
 
1 - 16 of 16 Posts
Top