Mitsubishi Eclipse 3G Club banner
1 - 7 of 7 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
2001 Eclipse GT spyder 5-speed.

Okay so I've started to get this really bad noise from the back of my car when I start it. This only happens after I start it up after driving for a while and the engine is completly warmed up. For example I would go to the store, and after shopping I would come back and come to my car and start it, it will make this crazy loud noise from the rear of the car and my idle will die to 150-300 and back up to 600. Most of the time I have to push the gas to keep it alive. Now, this noise also comes when I turn off the car. It happens from the back of the car, from both the passenger and driver side. It almost sounds like its coming from the gas tank.

Another thing it does: Lets say im crusing at 2000RPMs and i push the gas to take it up to 3000 to shift to the next gear, right when i push the gas i hear this slight grinding noise from the rear drivers side. I have a EGR code p0401, but this problems been happening before that. I have no idea what it is. All i can suspect is the fuel pump. :(

The noise is LOUD and roars in the inside of the car. It sounds like things rolling around in the trunk really loudly. Or something struggling to spin. It;s hard to describe, but I am almost 100% sure it has something to do with the fuel delivery system, due to the fact it's screwing with my idle and coming from the back of the car..

I also have a ticking noise during cold start thats pretty bad... Dont know if this has anything to do with anything
Hopefully you guys can help me... THANKS!!!
 

·
Registered
Joined
·
29 Posts
I'm having the same problem, my car is an 03 GT v6. I hear the rattling noise only on some days I start the car when the weather is cold. but after about a minute the car runs and sounds perfect...
its so weird
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top