Mitsubishi Eclipse 3G Club banner

1081 - 1100 of 1100 Posts

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,082
Nice. Is the lower compression due to the turbo? How long did it take to reinstall the engine?
Compression surprisingly is only a single variable when measuring cold cylinder psi. Cam overlap can play a big role in those tests. That being said, I'm at 8.8:1. If you squirt a oil into the spark plug hole, you can see to 230 PSI or above. Obviously too much oil.... If you start getting below 150 psi, it's not a good thing. Once my rings bed in, I'll do another compression check at the next spark plug change. See where they're at.

It's hard to say how much time because I could only do little things before I had other obligations that needed my attention. I guess a good long weekend timewise. I wouldn't claim to be fast rebuilding but I'm very thorough.
 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,088
Sheeeeiiiittt.... that’s no way to speak to the grandfather of Club 3g! Go moderate yourself, youngling!


Sent from my iPhone using Tapatalk
 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,089 (Edited)
So the breaking in of the motor continues. At initial start up I ran the car for a good 20 minutes or so. Immediately changed the oil and cracked open the oil filter. Saw a little bit of fine material. Typical for first start. Drove around for about 100 miles, pulled out and cracked open the second oil filter. Saw a very nominal amount of fine material. Drove for another hundred miles and cracked open the third oil filter... almost no visible material. Breakin is going well.
 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,090
Break-in complete! Fresh synthetic oil change. No sign of any material in the cut open filter. Still going to keep an eye on the higher rpms.
 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,092
I may do oil analysis sometime next year. I’ll drive through this oil and then do a compression check. I’ll have to change the plugs in the spring time anyway.


Sent from my iPhone using Tapatalk
 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,093
We’ve had some warm and dry weather of late, so I took her out to stretch her legs.

Happy holidays!

 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,094
Not really much of an update. I decided pull the Invidia catback. Got busted from law enforcement for noise ordinance.... for the second time by the same state trooper. Can't keep pressing my luck so the stock catback is on. Greg (Pharm) told me years ago to get a cut out and that's ultimately what I'll be doing. The cut-out is on its way. I am actually digging the muted sound. Can I actually have a conversation in the car now. lol
 

·
Moderator
Joined
·
974 Posts
I don't blame you. My car before this one had a louder borla on it and it was cool at first, but the highway sucked. The first thing I loved about this car is I can talk to people while driving on the highway. Also my ears don't ring when I get out of it.
 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,096
Exactly. I've been going back and forth on these cat-backs.... This one was my 2nd set of Invidias. I also have a set of Megans (I remember liking them but they didn't flow as well). The stocker just sounds good with low volume. The main issue is that the Ripp long tube headers are raspy.
 

·
Registered
Joined
·
82 Posts
Exactly. I've been going back and forth on these cat-backs.... This one was my 2nd set of Invidias. I also have a set of Megans (I remember liking them but they didn't flow as well). The stocker just sounds good with low volume. The main issue is that the Ripp long tube headers are raspy.
I have ebay shorties with a flow master highflow cat, flowmaster hush power 2 resonator and invidia exhaust. I personally love the sound and I have negative zero rasp and a gorgeous tone
 

·
Stage 1 SDS @11+ psi
Joined
·
2,975 Posts
Discussion Starter #1,098 (Edited)
Did a plug change. Had them gapped too big during the break-in period. I decided to check the compression and got 170 psi across the board. Can start WOT tuning soon.
 
1081 - 1100 of 1100 Posts
Top