Mitsubishi Eclipse 3G Club banner

1 - 20 of 43 Posts

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #1 ·
I cant redline...

it sounds like its redlining at around 5000, if i keep pushing it, i can get it to about 5500, but i think i hear misfiring, but i didnt throw a code.

has anyone heard of anything like this before?
 

·
5-Spd's FTW
Joined
·
1,595 Posts
I cant redline...

it sounds like its redlining at around 5000, if i keep pushing it, i can get it to about 5500, but i think i hear misfiring, but i didnt throw a code.

has anyone heard of anything like this before?
check your vacuum lines. my neighbors cobalt did that and it was from a vacuum leak.
 

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #6 ·
oh, bitter, thank you so much, my savior.

care to link me to where you found how to fix my car with the search?

thanks again,
Jambolito
 

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #9 ·
oh please, almighty bitter, please link me.

I must not be as competant as though holiness, for i cannot find the solution to my problem.
 

·
Moderator
Joined
·
54,424 Posts

·
Registered
Joined
·
665 Posts
It's supposed to do that. It's called a rev limiter. My sporty does the same thing. I've never done it on purpose, though. Just whenI forget I'm in sporty mode, haha.
 

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #12 ·
lets get this back to the problem report thread that it is.

I thought my "Vehicle: 2001 Spyder GT" would be enough to troubleshoot an problem with my valves, spark plugs, or anything of that sort.

I do have the diamante swap if that helps, i have denso iridiums also. if you may be able to help with more info, i will be more than happy to provide it.
 

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #13 ·
It's supposed to do that. It's called a rev limiter. My sporty does the same thing. I've never done it on purpose, though. Just whenI forget I'm in sporty mode, haha.
at 5500 malveaux? and its not like a regular rev limiter hit, theres no wah wah wah, its more like a .....hmm how to describe it... just like it stops climbing, it just stays there at ~5500....
 

·
Registered
Joined
·
665 Posts
at 5500 malveaux? and its not like a regular rev limiter hit, theres no wah wah wah, its more like a .....hmm how to describe it... just like it stops climbing, it just stays there at ~5500....
Ahh, That is different. hmm so it doesn't bounce of the limiter...
 

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #17 ·
intake, exhaust, headers, last maintenance done? read the 1st link i posted and rewrite your first post to fit the guidelines for this forum.
AEM short ram, Diamante manifold swap
Greddy Evo
stock headers
changed spark plugs 3,000 miles ago, changed to magnecor wires but they wouldnt seat, so put stock plugs back on.

Im not going to rewrite my post, this is the extra info you requested. If you want to give someone a hard time, take it to OT, this is a viable problem with no reason to argue anymore.
 

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #18 ·
Ahh, That is different. hmm so it doesn't bounce of the limiter...
the symtoms sound similar to the threads bitter linked me to, but i dont think an aftermarket intake would be able to suck up against anything well enough to close off my air flow.

It really sounds to me like some kind of a vac leak, but i checked all of my hoses with carb cleaner.
 

·
Registered
Joined
·
1,690 Posts
the symtoms sound similar to the threads bitter linked me to, but i dont think an aftermarket intake would be able to suck up against anything well enough to close off my air flow.

It really sounds to me like some kind of a vac leak, but i checked all of my hoses with carb cleaner.
Other places can be sources of vacuum leaks such as intake manifold gaskets, etc. Does it have any other symptoms of a vacuum leak...usually you'd have a hunting idle, etc.

The reason why Bitter linked to that sticky I put together is so we can get an overall idea of what we're dealing with without having to give you the third degree...think of it as taking the car to the dealer...they can actually see what your car has on/in it (we can't), but they'd also want to know when it happens, when it doesn't happen, what other things you notice, etc. At this point, we don't even know if you have a sporty or manual tranny. It's always best to give more info than is needed rather than trying to focus in on one aspect...a lot of times, problems are a result of a condition that seems completely unrelated.

Also, have you been able to go above 5500 RPM before? If so, what if anything has been done to the car since you were last able to go above that RPM? Do you see where we're going here...we're not trying to be jerks, we just need a little more info in order to properly help you...otherwise, the majority of suggestions you'd get would be the typical noob responses such as "oh, you need to replace part x because that's what it was for my friend"...think of it like Jerry Mcguire...help us, help you...:bigthumb:
 

·
Premium Member
Joined
·
1,152 Posts
Discussion Starter · #20 · (Edited)
Its not hunting idle, and its really hard to get a base comparison here because i had magnecor plugs on for about 3,000 miles. They never really seated correctly, but that wasnt a problem until the higher RPMs, so i put my stock wires back on.

I got pretty much all of my power back, and this is the last of my problems.

(it is a sporty)

and I dont think it would be the intake manifold gasket, I put a new one on when i did the diamante manifold swap, which was also about 3,000 miles ago. I would try to blame it on the manifold, but i screwed up the vac lines and Greg put everything where it needed to be...
 
1 - 20 of 43 Posts
Top